Je eigen sterrenwacht

To UPs or not to UPS ?

  • This topic contains 47 replies, has 5 voices, and was last updated by  Bakx 2 months ago.
Viewing 15 posts - 31 through 45 (of 48 total)
  • Author
    Posts
  • #21349

    InFINNity Deck
    Participant
    posts: 119

    De UPS (mag ook een ander model zijn) is in zoverre noodzakelijk, dat deze het shutdown commando naar de pc stuurt. Je kan het script zonder UPS testen door MountCMD.bat handmatig uit te voeren (gewoon dubbelklikken op het bestand), al adviseer ik wel het ook volledig te testen. Ik heb dit gedaan door voor de minimale shutdown tijd te kiezen (1 minuut) en vervolgens de stekker uit de UPS te trekken. Daaraan voorafgaand heb ik ook de lan-verbinding met mijn router verbroken door die kabel uit de switch te trekken.

    Zelf heb ik nog veel meer op de UPS zitten, maar dat was alleen maar omdat ik een hoofdschakelaar in het observatorium heb waarmee ik de montering en de aansturing van de koepel in één keer kan aan- en uitschakelen (24V power supply mount, schakelvoeding H-brug, acculaders koepel). Daarnaast heb ik een van de andere uitgangen van de UPS nog gebruikt om zaken, die niet met de hoofdschakelaar aan- of uitgeschakeld mogen worden, van noodstroom te kunnen voorzien (beeldscherm, switch, NUC). De rest (voeding camera’s, dauwlinten, focuser) vallen gewoon gewoon uit bij stroomuitval.

    Het werk heb ik er graag in gestoken, want anders had ik nu nog steeds een niet tegen stroomuitval beveiligd observatorium gehad. De afgelopen jaren hebben we hier in Castricum meerdere malen hiermee te maken gehad, soms meerdere uren…. Jij dus nog bedankt voor het starten van dit onderwerp!

    Nicolàs

     

    #21365

    Bakx
    Participant
    posts: 100

    Ik heb vanavond het script uitgeprobeerd.Het werkt.De mount wordt netjes geparkeerd en sluit af als ik de PC uitzet. De dome shutter gaat dan ook netjes dicht. Helemaal top.

    Maar……

    Als SGP bezig is, en dat is meestal bij mij, voorkomt SGP dat windows afsluit. En stopt het daar……..

    Ook na een tijdje wachten, blijft het afsluiten van de PC hangen.

    #21366

    InFINNity Deck
    Participant
    posts: 119

    Hoi Arie,

    Dat had ik nog niet getest. Momenteel ben ik niet thuis, maar komend weekend ga ik hier naar kijken.

    Nicolàs

    #21367

    InFINNity Deck
    Participant
    posts: 119

    Hoi Arie,

    Kan jij de laatste post in dit draadje eens proberen, ik kan het hiervandaan even niet testen.

    https://forums.apc.com/spaces/7/ups-management-devices-powerchute-software/forums/general/84875/powerchute-not-hibernating-pc

    Nicolàs

    #21368

    Bakx
    Participant
    posts: 100

    C:\Windows\System32\shutdown.exe /s /t 5

     

    Ik vond deze op internet. Die doet een forced shut down.

    Kan ik die gewoon toevoegen aan het .bat file?

    #21369

    InFINNity Deck
    Participant
    posts: 119

    Dat zal waarschijnlijk niet werken. Het probleem is dat het batch-file niet wordt aangeroepen. Door de software van de UPS te verwijderen kan je gebruik maken van de Windows-eigen shutdown routine. Hopelijk kan die een forced shutdown doen.

    Nicolàs

    #21370

    Bakx
    Participant
    posts: 100

    Ik dacht dat de UPS een .bat file kan aanroepen op de PC  waarmee hij verbonden is?

    Als ik dubbellik op het .bat bestand werkt het.

    De mount gaat netjes plat en windows gaat in shut-down.

    Dan komt er ineeens weer een zwarte CMD box die toont dat er nog een aantal keren wordt geprobeerd iets met de mount te doen. ( het proces wordt, zoals het lijkt, herhaald) En na een minuutje of zo gaat ie verder met de shut-down.

    En dan is alles uit . . . . . . . . en safe!

    Maar als ik het nu goed begrijp, moet ik eerst zo’n ding kopen en aansluiten en dan uitvogelen hoe hij moet werken?

    • This reply was modified 2 months, 3 weeks ago by  Bakx.
    #21372

    InFINNity Deck
    Participant
    posts: 119

    Hoi Arie,

    Dat je nu twee keer ziet dat het script de montering probeert uit te zetten, klopt. Je dubbelklikt het script met jouw shutdown toevoeging en die triggert weer de shutdown-instelling die ik eerder voorgesteld had en jij inmiddels hebt geïmplementeerd.

    De APC UPS die ik gebruik, kan geen .bat aanroepen. Ik heb vandaag wel twee goede work-arounds gevonden, maar die kan ik vrijdag pas testen als ik weer thuis ben.

    Er schijnt ook nog een oplossing binnen SGP te zijn (via de safety monitor), maar die vereist een ASCOM driver voor de UPS en die heb ik (nog) niet kunnen vinden.

    Heel even geduld dus aub, ik ga dit voor ons oplossen.

    Nicolàs

     

    • 1 person likes this.
    #21374

    Bakx
    Participant
    posts: 100

    Top!

    Naast het zoeken naar een UPS oplossing heb ik afgelopen nacht een uitvoerige test gedaan van ModelCreator V2.  Ik ben betatester voor de auteur, met name de dome synchronisatie kan ik voor hem doen.

    Nou dat was dus helemaal niks. V1 is stukken beter. Dus daar moet nog een ander aan geschreven worden.

    Om half twee vond ik wel welletjes in mijn koepeltje. Het werd koud en ik kreeg slaap. (hoe is’t mogelijk )

    Nog even gauw wat frames geschoten van M51, om de BF-spacing te checken van de Atik 16200. Dat is weer iets beter, maar er zit een behoorlijke tilt van links naar rechts. Dit is een gecropte versie. Alles van na drie uur was al weer te licht. Dus krap 1,5 uur LRGB kunnen doen. Bewerking is niet veel. Maar het blijft leuk !! Eindelijk weer eens een plaat. . .

    Arie

    • This reply was modified 2 months, 3 weeks ago by  Bakx.
    • 2 people like this.
    #21380

    InFINNity Deck
    Participant
    posts: 119

    Ik heb het vandaag twee keer getest met SGP werkend, zelfs tijdens het integreren binnen een sequence met de camera op -20°C. Filterwiel, weerstation (MGBox V2), focuser en LesveDome waren ook aangesloten. Tegelijkertijd had ik de virtual handcontroller, MountMonitor, Stellarium en TimeSynch draaien.

    Met mijn instellingen allemaal toegepast, krijgt geen van deze applicaties ook maar de kans te reageren. Zodra de UPS ingrijpt, dan gaat het scherm meteen op blauw (met de mededeling “Afsluiten”) en gaat het vervolgens over op zwart of blauw (dat wisselt nogal eens) en het zwarte CMD-window dat het .bat bestand verwerkt. De eerste 10 seconden gebeurt er uiteraard niets, daarna gaat de montering parkeren, vervolgens gebeurt er 30 seconden niets, waarna zowel de montering als de pc afgesloten worden.

    De UPS die ik gebruik geeft een shutdown actie, ik vermoed zelfs forced, en zou het dus moeten winnen van eender welke applicatie.

    Overigens is het nog goed te melden, gezien een opmerking op het 10Micron forum, dat bovenstaande oplossing alleen op de PRO editie van Windows 10 werkt, de home editie staat niet toe de benodigde tweaks uit te voeren.

    Nicolàs

    #21436

    InFINNity Deck
    Participant
    posts: 119

    Vandaag heb ik voor SGP een SafetyMonitor Generic UPS driver geschreven die ervoor zorgt dat SGP de sequence afsluit en de End Of Sequence options start. Op deze manier worden de montering en gekoppelde dome netjes geparkeerd en de camera fatsoenlijk opgewarmd. Het enige dat niet geregeld is, is het uitschakelen van de montering, maar dat kan met het eerder beschikbaar gestelde MountCMD.

    Voor meer informatie over de Generic UPS driver voor SGP, zie http://forum.mainsequencesoftware.com/t/ups-and-safety-monitor/9965/31

    Houd er rekening mee dat de SafetyMonitor pas werkt nadat de eerste foto genomen is. Mocht het nodig zijn de sequence pas na een paar uur te starten, dan kan een tweede target aan het sequence worden toegevoegd. Het eerste target is slechts om de SafetyMonitor te activeren (neem slechts 1 foto in dat target). Het tweede target dient dan de volledige sequence te bevatten.

    Nicolàs

     

    • 2 people like this.
    #21438

    Groenewold
    Moderator
    posts: 1155

    Wauw, gaaf! Welke taal heb je hiervoor gebruikt?

    #21439

    InFINNity Deck
    Participant
    posts: 119

    Het is geschreven in Visual Studio met C# .NET.

    Momenteel is @ariebakx aan het kijken of hij hem met zijn UPS aan de praat kan krijgen. Graag hoor ik of anderen deze driver ook willen gebruiken en of daarvoor aanpassingen nodig zijn. Hopelijk zal dat uiteindelijk tot een echte generic driver leiden die met elk type UPS (of in ieder geval zoveel mogelijk types) gebruikt kan worden.

    Er is nog één ‘kleinigheidje’: momenteel is de SafetyMonitor vooral bedoeld om naar het weer te kijken en op basis daarvan het observatorium te sluiten. Er is echter maar ruimte voor één SafetyMonitor in SGP. Dit punt is al een tijdje geleden aangekaart op het SGP forum.

    Nu er een generic UPS monitor is, zal er hopelijk wat beweging in komen.

    Nicolàs

    • 1 person likes this.
    #21444

    Bakx
    Participant
    posts: 100

    Na een middagje inTeam (viewer) samenzijn met Nicolàs, waarbij Nicolàs zich helemaal uit heeft kunnen leven in mijn dome-PC (NUC) kan ik het volgende melden:

    Ik heb vanmiddag even een full-run gedaan.
    Een sequence gemaakt en gestart.
    Na een paar minuten de hoofdschakelaar om.
    De UPS nam het netjes over.
    De melding van de UPS kwam direkt.
    Na 5 minuten (setting) ging het groene lampje in SGP op rood en kwam de waarschuwing dat er een EOS uitgevoerd zou worden.
    Nou, dat gebeurde dus ook.
    Dome dicht en in parkeerstand, mount in parkeerstand.
    Nog even wachten en 5 min later ging de NUC het afsluittraject in.
    MountCMD zette de mount uit en toen was het stil………..

    Nu moet ik nog wat verder aan het stoeien met alle instellingen van UPS.
    Want ook de hele UPS was er al mee opgehouden.
    Dus die moest ik eerst resetten en toen deed ie het weer.
    Ik meende dat ik hem zo had gezet dat de UPS zelf pas uitgaat bij 10% residual power.
    Maar ik zal dus ook ergens wel aangevinkt hebben dat ie meteen of na een paar minuten  de PC achterna gaat. Dat weet ik even niet.
    Ik zat nog even in mijn rats toen de mount aan het afsluiten was, dat de UPS niet op dat moment de stroom eraf zou gooien. Maar dat ging (toevallig?) goed.
    Anders moet ik dat afsluiten van de mount toch maar iets eerder laten doen door dat .cmd bestandje van de UPS software te laten draaien.

    De UPS geeft 59-60 minuten runtime. Tijdens het sluiten van de shutter viel dat terug naar 45 minuten om daarna weer op 60 min te gaan staan. Power zat dus.

    Je kunt dus met een gerust hart op je website vermelden dat het ook op een Cybercom met PPBE werkt. Wellicht dat het met het simpele programmaatje net zo werkt. (En veel minder instellingen….)

    Arie

    • 3 people like this.
    #21445

    InFINNity Deck
    Participant
    posts: 119

    Hoi Arie,

    moooooooi!
    Goed dat je een volledige test gedaan hebt. Nu inderdaad nog wat fine-tunen met de tijden en het moment van uitzetten van de mount en je bent gesteld. Voor wat die UPS betreft: het is goed deze procedure tenminste een keer per jaar te doen om te zien alles nog werkt, zeker als er nieuwe firmware in de UPS zit of PPBE geupdate wordt.
    Verder is het zaak regelmatig de kwaliteit van de batterij van de UPS te controleren en zo nodig de timing eraan aan te passen.

    Bij de ASCOM club werd mijn gerommel ook gewaardeerd, sinds vandaag sta ik op de ASCOM ‘hall-of-fame’: https://ascom-standards.org/Downloads/SafetyMonitorDrivers.htm

    Nicolàs

    • 4 people like this.
Viewing 15 posts - 31 through 45 (of 48 total)

You need to log in or to reply to this topic.